0 支持
313 閲覧
質問 Q&A
UE4.19.2にて親にSsPlayerWidgetを配置し階層内にテキストボックスを配置したんですが、テキスト内にあるReflect Part Alphaのチェックを入れてもSpriteStudioパーツのアルファが反映されない現象が起きています。

親に配置しているRenderModeは「UMG Default」に設定し、テキストを配置する為のNullは【フォントの表示エリアを定義する】を参考に配置してあります。

不透明度は「ローカル不透明度」ではなく「不透明度」でアルファ値を設定しています。

何か設定をしなくては表示しないのでしょうか…?

ご確認願います。

回答 1

0 支持
(280 ポイント) 回答
お問い合わせありがとうございます。

ご指摘の状況で、子階層に「不透明度」が反映されず、完全に透明になってしまう状態を確認致しました。
この問題は、セルが未設定のパーツを非表示とみなしてしまい、アルファ値をゼロ扱いしてしまうためでした。

developブランチに修正をプッシュ致しました。
UE4.19での使用の場合、下記の差分を適用して頂く必要が御座います。
https://github.com/SpriteStudio/SS6PlayerForUnrealEngine4/commit/0bddf2c58068f24a1cdb451b14cbfc3205117e07#diff-5f9ec644848f39e60ab0d38516cde043

チームにプログラマが居ない等で適用方法が分からない場合は、お使いのプラグインバージョン(UE4.19であれば "v1.1.3"~"v1.2.1")をお知らせ頂ければ、差分を適用したビルドをご用意致します。

また、本修正適用後でも、パーツ自体が非表示の場合には子階層が非表示になるのは仕様となります。
セル無しの状態では表示状態が分かりにくいので、「非表示」アトリビュートがOFFの状態でキーが打たれていることをご確認下さい。
(100 ポイント) コメント

修正有難うございます。

PGに頼んで適用して頂きましたがアニメーションを再生させた所、エディター上では問題なく動くのですが、Switch環境ではアニメーションを再生した瞬間にクラッシュしてしまいました。

こちら一度ご確認いただけないでしょうか…

(5.7k ポイント) コメント

こんにちは。取り急ぎご返信いたします。

SS6P for UE4にはSwitch環境でクラッシュしてしまう問題がございました。
(v1.2.0 RenderModeをUMG_ OffScreenのSsPlayerWidgetのアニメーションを再生するとクラッシュする)
本問題につきましては対処を行っておりますので、以下のissueをご確認いただき、差分の適応をお願いいたします。
https://github.com/SpriteStudio/SS6PlayerForUnrealEngine4/issues/6

こちらのissueをご確認・適用いただいてもクラッシュしてしまう場合、原因の調査のため、GitHubのissueに症状をご投稿いただくか、技術サポートまで改めてお問い合わせいただけますと幸いです。

▼SS6P for UE4 issue
https://github.com/SpriteStudio/SS6PlayerForUnrealEngine4/issues

▼技術サポートお問い合わせフォーム
https://www.webtech.co.jp/help/ja/spritestudio/inquiries/usages_funcitons/

ご迷惑をおかけし申し訳ございません。何卒よろしくお願いいたします。

OPTPiX SpriteStudio コミュニティへようこそ!
はじめての方はユーザー登録してください。
サイト内検索
情報はヘルプセンターにも掲載されています。合わせてご覧ください。

ヘルプセンターの逆引き  リファレンスをチェック


投稿はこちらから

Q&Aへ投稿
要望へ投稿
掲示板へ投稿
バグ報告へ投稿

ホット!
未回答の投稿
すべての投稿
ユーザー

カテゴリー

...