0 支持
82 閲覧
(120 ポイント) Q&A

質問させていただきます。

SpriteStudioで作ったプロジェクトをUnityにインポートして表示させたいのですが、SS6PlayerForUnityでインポートする際、Inport Modeを「Convert To Unity-Native」に設定してインポートし、出力されたプレハブをヒエラルキー上に配置すると、シーン上に表示されません。
Main Cameraにも、Camera2D Pixel (720p)カメラにも映らない状況です。
エラー等は特に出ていません。

Inport Modeを「SS6Player」でインポートした場合、問題なくカメラに写っています。


何か原因になるようなことがありましたら、ご教授いただけますとご大変助かります。

以下に各使用バージョンを記述いたします。
お手数ですが、何卒よろしくお願いいたします。


▼使用バージョン
・SpriteStudio7 バージョン : 7.0.4.4335
・SpriteStudio 6 Player for Unity 2.1.8
・Unity2019.4.40f1

このページをシェアする

回答 2

0 支持
(1.4k ポイント)
編集
OPTPiX ユーザーサポート 大野です。

ご質問のありました、”インポートし、出力されたプレハブをヒエラルキー上に配置してもシーン上に表示さない”件ですがこちらのページの手法をお試しいただけますでしょうか。
お手数ではありますがご確認いただけましたら幸いです。
https://www.webtech.co.jp/help/ja/spritestudio7/guide/output/unity_native/#animation

こちらもご確認ください。
https://github.com/SpriteStudio/SS6PlayerForUnity/wiki/%E3%82%A4%E3%83%B3%E3%83%9D%E3%83%BC%E3%82%BF%E3%81%AE%E8%A9%B3%E7%B4%B0%E8%A7%A3%E8%AA%AC%EF%BC%88%E3%80%8CUnity-Native%E3%80%8D%E3%83%A2%E3%83%BC%E3%83%89%EF%BC%89#%E3%82%A2%E3%83%8B%E3%83%A1%E3%83%BC%E3%82%B7%E3%83%A7%E3%83%B3%E3%81%AE%E3%82%B7%E3%83%BC%E3%83%B3%E9%85%8D%E7%BD%AE%E5%BE%8C%E3%81%AB%E5%BF%85%E8%A6%81%E3%81%AA%E4%BD%9C%E6%A5%AD

もし既にお試しである、もしくは試してみても表示されないようでしたら他の問題かもしれませんので、再度コメントいただけますでしょうか。

ご確認よろしくお願いします。
(120 ポイント)

詳しいご返答をありがとうございます。
ご提示いただいたurlの内容を試してみました。
--------------------

https://www.webtech.co.jp/help/ja/spritestudio7/guide/output/unity_native/#animation

こちらの手順を進めた際、
>プレハブをシーンに配置する
の項目は問題なく出来ています。

>カメラを準備する
の項目に関しまして、Camera2D Pixel (720p)カメラをヒエラルキー上に配置した後、マニュアルの画像ではシーン上に画像が表示されているようですが、自分の環境では表示されません。

しかしUnityを再生するとカメラに画像が表示され、アニメーションも問題なく動いています。

Camera2D Pixel (720p)カメラ、MainCameraのどちらもそうなります。

--------------------

https://github.com/SpriteStudio/SS6PlayerForUnity/wiki/%E3%82%A4%E3%83%B3%E3%83%9D%E3%83%BC%E3%82%BF%E3%81%AE%E8%A9%B3%E7%B4%B0%E8%A7%A3%E8%AA%AC%EF%BC%88%E3%80%8CUnity-Native%E3%80%8D%E3%83%A2%E3%83%BC%E3%83%89%EF%BC%89#Notes-ComponentAnimator

こちらを試してみました。
以下箇条書きになりますが、状況を記入いたします。

・インポートは「Create Control-Prefab」と「Create Asset-Holder」を双方ともチェックした状態で、Convert To Unity-Nativeモードで行っています。

・オブジェクトのTransformのPositionはX=0, Y=0, Z=0 

・オブジェクトのTransformのScaleはX=1, Y=1, Z=1

・カメラのTransformのPositionはX=0, Y=0, Z=0・ScaleをX=1, Y=1, Z=1

・カメラのNearクリップ・Farクリップに関して、Unityを再生した際は全てのパーツが問題なく表示されている

・rootオブジェクトについているScript_SpriteStudio6_Rootのインスペクタには「Hide Force」の項目が見当たらない

以上を確認しまして、やはりUnityを再生していない状態だとカメラにオブジェクトが映らない状態です。

--------------------

長くなり申し訳ありません。

お手数をおかけしますが、ご確認をお願いいたします。

(1.4k ポイント)
OPTPiX ユーザーサポート 大野です。

ご確認いただきましてまことにありがとうございます。弊社でも調査を行いますので少々お待ちいただけましたら幸いです。

よろしくお願いします。
(1.4k ポイント)
OPTPiX ユーザーサポート 大野です。

頂いた情報を元に弊社で確認を行ったところ、初期状態でアニメーションクリップを定義してない可能性かあるかもしれません。
定義していない場合表示されません。

(Unity-Nativeモード時はアニメーションデータがないと、最初のフレームを表示するのに必要なデータがない状況となります)

アニメーションオブジェクトに対応したAnimationClipを定義することで表示される可能性がございますのでお試しいただけませんでしょうか。

https://github.com/SpriteStudio/SS6PlayerForUnity/wiki/%E3%82%A4%E3%83%B3%E3%83%9D%E3%83%BC%E3%82%BF%E3%81%AE%E8%A9%B3%E7%B4%B0%E8%A7%A3%E8%AA%AC%EF%BC%88%E3%80%8CUnity-Native%E3%80%8D%E3%83%A2%E3%83%BC%E3%83%89%EF%BC%89#After-Put-Animation

ご確認いただけましたら幸いです。
よろしくお願いします。
(120 ポイント)

ご確認いただきありがとうございます。
以下の手順を確認してみました。

https://github.com/SpriteStudio/SS6PlayerForUnity/wiki/%E3%82%A4%E3%83%B3%E3%83%9D%E3%83%BC%E3%82%BF%E3%81%AE%E8%A9%B3%E7%B4%B0%E8%A7%A3%E8%AA%AC%EF%BC%88%E3%80%8CUnity-Native%E3%80%8D%E3%83%A2%E3%83%BC%E3%83%89%EF%BC%89#After-Put-Animation

こちらの手順でAnimatorコンポーネントは作成できているはずなのですが、やはり再生しないとシーン上のカメラに映らない状況です。

①ps_●●●_Controlプレハブをシーン上に配置

②rootに該当するオブジェクトについているScript_SpriteStudio6_HolderAssetUnityNativeのTabel Animation ClipからアタッチされているAnimationClipを探す

③見つかったAnimationClipをrootに該当するオブジェクトにドラッグ&ドロップ(Animatorコンポーネントが生成される)

④Camera2D Pixel プレハブをシーンに配置

このような流れで作業していますが、間違いがありそうでしょうか?

画像を添付いたします。

(120 ポイント)
追記です。

上記の状態で、Animation Windowを開き、一番最初のキーを選択すると、その時は再生中でなくともシーン上に画像が表示されました。
(1.4k ポイント)
編集
OPTPiX ユーザーサポート 大野です。
ご返答遅くなりまして申し訳ありません。

ご利用のバージョンが2.1.8とのことですが、こちらのVer.2.1.19をお試しいただく事は可能でしょうか。
https://github.com/SpriteStudio/SS6PlayerForUnity

改善する可能性がございます。
お手数ではありますがご確認よろしくお願いします。
(120 ポイント)
編集
確認が遅くなり申し訳ありません。

>ご利用のバージョンが2.1.8とのことですが、こちらのVer.2.1.19をお試しいただく事は可能でしょうか。

こちらで解決し、Unity再生時でなくとも素材がシーン上に表示されるようになりました!ご返答いただきありがとうございました。大変助かりました。
(1.4k ポイント)
OPTPiX ユーザーサポート 大野です。

表示されたとのことで安心いたしました。

引き続きご利用いただけましたら幸いです。

よろしくお願いします。
0 支持
(530 ポイント)

I have encountered similar problem before. 

Finally I find that the key point is that we have to add an Animator component to the generated prefab.

If there is no Animator on the generated prefab, it won't display anything on the scene.

...